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ABSTRACT 
 
FEMAP is a robust Finite Element Model (FEM) 
pre- and post-processor whose primary strengths are 
the ability to import and export many geometry and 
FEM formats and its intuitive and easy to use 
interface for building models.  A primary advantage 
to Finite Elements for thermal analysis is the 
automatic generation of the conduction network.  
Until recently, however, the radiation network 
generation, was not well supported.  With the 
development of tools like Thermal Desktop (and 
TMG), the radiation network can also be computed.  
Thermal Desktop supports the import of a FEMAP 
neutral file, including nodes, elements, properties, 
and materials (and most importantly optical 
properties).  Therefore the combination of these two 
tools allows for the rapid construction of analysis 
models based on solid models from a mechanical 
designer and a better interface to the design 
evolution by the thermal subsystem.  This paper 
serves as an introduction to the thermal engineer as 
to the basic construction techniques used to build a 
finite element model from a solid model and 
provides some suggestions to consider when using 
the FEM as the basis for a Thermal Desktop model.  
 
1. INTRODUCTION 
 
Traditionally, two methods of thermal modeling 
have been used: finite difference and finite element.  
In both cases, a matrix of terms is generated and 
solved to determine temperatures.  While many 
commercially available thermal codes have 
supported finite element capabilities, the generation 
of a mesh has not been particularly easy.  Some 
commercial thermal codes have begun to include 
automatic element generation capabilities for quick 
generation of a mesh suitable for thermal analysis; 
others have provided interfaces to existing 

meshing/FE programs.  Conversely, structural codes 
rely almost exclusively on the finite element 
approach, but lack the radiation and orbital 
capabilities of thermal codes.  The FEMAP® 
program (Finite Element Modeling And Post-
processing) includes an intuitive and easy to use 
interface, the ability to import and export many 
formats (both geometry and FE), and robust 
automatic mesh generation capabilities.  Using 
various export capabilities from FEMAP and import 
capabilities of the destination thermal code, the 
majority of the effort to build a detailed finite 
element thermal model can be performed in 
FEMAP.  The FEM can then be made into a thermal 
model, complete with orbital and electrical heating, 
radiation exchange, and other features of thermal 
models using Thermal Desktop®/SindaFluint, 
IDEAS/TMG, TSS/SINDA, or SINDA/ATM.  This 
paper provides an introduction to basic Finite 
Element modeling techniques and provides 
recommendations based on the efforts and lessons 
learned from generating the Laser Interferometer 
Space Antenna (LISA) models using FEMAP and 
Thermal Desktop. 
 
2. BASIC FEM TECHNIQUES 
 
Most finite element codes support a common set of 
analysis objects (Material, Property, Node, 
Element, Load) and geometry objects (Point, Curve, 
Surface, Solid / Volume).  A Material defines the 
material properties to be used for computing the 
interaction between nodes.  For a thermal model, 
the relevant material properties are density, specific 
heat, and thermal conductivity.  If radiation is to be 
included, then front side and reverse side thermo-
optical properties should also be included.  A 
Property references a particular Material but 
defines additional parameters specific to a set of 
Elements, such as thickness (for 2D elements) or 



- 2 of 6 - 

cross sectional area (for 1D elements).  This allows 
for the same material to be used numerous places 
where the physical geometry may be different.  
Nodes define specific locations in XYZ space where 
a value (e.g. temperature) should be calculated.  The 
interaction between Nodes is defined by Elements.  
An Element is defined by 2 or more nodes and a 
Property (which in turn defines the Material to be 
used for the Element). 
 
A model could be built by specifying the location 
for each individual node and building each element 
manually, but this would be extremely tedious.  
Fortunately, a user can define the number of nodes 
along a curve or surface or the desired element size 
and allow FEMAP to automatically generate the 
corresponding mesh.  To do this, it is helpful to 
understand the geometry hierarchy.  The most basic 
element for geometry is a Point, which, like a node, 
is simply a point in XYZ space.  Points are used to 
define Curves, which may be arcs or straight line 
segments.  Three or four Curves are used to define 
Surfaces, which need not necessarily be planar.  
More complicated surfaces may be defined using 
boundary surfaces, which allow for cutout sections 
such as holes.  Lastly, Surfaces are combined to 
form Solids.  A variety of operations may be 
performed on solids, such as slicing, exploding, and 
add/subtract Boolean operations. 
 

 
Figure 1 – Different Mesh Discretizations 

 
Once the geometry is defined, it can be meshed 
using automatic or mapped meshing algorithms.  
Automatic meshes tend to be less ordered than 
mapped meshes.  The mesh on the left of Figure 1 
was automatically generated based on an average 
element size.  The mesh in the middle was based on 
6 elements along the outer sides and 12 around the 
cutout.  Lastly, the mesh on the right was based on 
3 elements along each side of the top left section 
and reflecting the elements about lines of symmetry.  
Mapped meshes are best suited for simpler 
geometries; while automatic mesh generation is 
better for complicated surfaces/solids. 
 

3. FEMAP INTERFACE 
 
Figure 2 shows the FEMAP v9.0 interface which 
features components found in many Windows based 
programs, including a menu and toolbars at the top.  
The left side includes a Model Info tree, where 
entities in the model can be selected.  The 
corresponding properties of the selected entity are 
shown in the Entity Editor window below the object 
tree.  The right side features the main visualization 
window and command log/response messages.  The 
menus follow a logical progression for model 
generation: File, Tools, Geometry, Model, Mesh, 
Modify, List, Delete, Group, View, Window, and 
Help as shown in Figure 3.  Frequently used 
functions for each menu are described in Table 1.   
 

 
Figure 2– FEMAP Interface 

 

 
Figure 3– FEMAP Menu 

 
Menu Functions 
File load existing models, save model, importing 

and exporting, save image 
Tools Measure distances, check for coincident entities 
Geometry Generate geometry entities (Points, Curves, 

Surfaces, etc) anew or from existing versions 
(rotate, copy, reflect, etc.) 

Model Generate Materials, Properties, Nodes or 
Elements 

Mesh Element/curve sizing, automatic or mapped 
mesh generation, generation of new elements 
from existing ones 

Modify Change features of all existing entities  (Nodes, 
Materials, Elements, Properties, etc) 

List Display information for selected entities 
Delete Remove selected entities from model 
Groups Create Groups for display/selection purposes 
View Set viewpoint, control visibility of entities 

Table 1 – Major Menu Functionality 



- 3 of 6 - 

4. MAKING A MESH FROM SOLID MODELS 
 
Unfortunately, a typical solid model from a 
mechanical designer cannot be used “as is” to 
generate a mesh suitable for thermal analysis.  
Often these models include features not needed for 
thermal analysis, including: bolts, holes, chamfers, 
fillets, slots, etc.  The solid model for the current 
LISA design is shown in Figure 4.   
 

 
Figure 4 – Sample Solid Model for LISA 

 
This model includes many features that will not be 
preserved when a mesh is built, such as: electronics 
box mounting feet, baffles in the telescope shield, 
and fillets on the payload shield.  However, the 
points used to define the solids model’s curves and 
surfaces can be used to create intermediate points, 
curves and surfaces useful for making simplistic 
representations of solid model components.  Figure 
5 shows a section of the solid model with the 
payload shield “ghosted” to show some of the 
internal components.  Figure 6 shows the simplistic 
geometry that was later used to define the mesh on 
the surfaces. 
 

 
Figure 5 – Solid Model Representation 

 
Figure 6 – Simplified Surface Representation 

 
It is up to the analyst to determine the appropriate 
element type suitable for analysis.  While a wide 
variety of element types are supported by FEMAP, 
not all of them translate properly into Thermal 
Desktop.  Generally, thermal analysts should use 
bar, plate, and solid element types when exporting 
to Thermal Desktop.   Typically, thinner sections 
(e.g. thin walls, panels) are represented with plate 
elements, bolts are represented with bar elements, 
and thicker sections are represented with solid 
elements.  It should be noted that typically only 
plate elements are included in radiation.  Therefore, 
to include radiation from solid elements, a shell coat 
of zero thickness plate elements can be applied to 
the free faces.  One benefit to using solid elements 
is that they may reference anisotropic materials (kx 
≠ ky ≠ kz), such as a honeycomb core.  To correctly 
model this, the material orientation must also be 
defined to specify the x, y, and z directions.  For 
example, the honeycomb panels in the LISA model 
included plate elements for the outer facesheet, 
anisotropic solid elements for the honeycomb core, 
and plate elements for the inner facesheet.  This 
allowed for the proper simulation of radiation from 
both sides of the honeycomb panel as well as 
including the anisotropic conductivity of the 
honeycomb core.  Figures 7-11 show the solid 
model section and the resulting finite element mesh. 
 

   
Figure 7 – Solid Model (Left) vs. FEM (Right) 
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Figure 8 – Solid Model (Left) vs. FEM (Right) 

 

          
Figure 9 – Solid Model (Left) vs. FEM (Right) 

     
Figure 10 – Solid Model (Left) vs. FEM (Right) 

 

 
Figure 11 – Solid Model (Top) vs. FEM (Bottom) 

5. MESH VALIDATION AND MODEL ORGANIZATION 
 
Once a mesh is generated, model checks should be 
performed to ensure that the resulting thermal 
model will be correct.  First, element normal 
directions should be verified.  Elements generally 
follow the right hand rule to determine the +Z (or 
front) side of the element.  If front side thermo-
optical properties are defined for the material used 
by the element, then these properties will be used 
for the +Z side of the element.  Conversely, if 
properties are defined for reverse side, then these 
properties will be assigned to the –Z side of the 
element.  Unfortunately, reverse side thermo-optical 
properties cannot be assigned without first assigning 
front side properties.  If only one side of an element 
is radiating, then the element normal must point in 
the direction of the element’s field of view for 
proper radiation view computation.  FEMAP has the 
capability to visually display the element normal 
direction via arrows or backface shading. 
 
Nodes must also be merged to ensure that 
connections exist between all sections of a model.  
It is important to realize that heat flows through 
nodes; therefore, to correctly simulate interfaces, 
components must share nodes or be explicitly 
connected by elements.  To merge nodes, the user 
specifies an allowable tolerance for two nodes to be 
separated; any nodes within this tolerance will be 
merged together.  Elements referencing either of the 
two nodes are updated to reflect the remaining node 
number.  Coincident nodes connected by a bar 
element will be listed, but will not be merged.  
Before merging nodes, the user is advised to check 
which nodes will be merged to ensure that 
unintended mergings are not performed.  FEMAP 
provides the option to create two groups of 
coincident nodes (remaining and replaced nodes) if 
further investigation is needed.  Similar capabilities 
exist for detecting coincident elements, to ensure 
that a surface was not meshed twice. 
 
Once all nodes have been merged, it is advised to 
logically renumber nodes and elements so that 
associations with particular components or regions 
of the model can be identified.  For example, the 
Solar Array nodes and elements may be numbered 
starting with 10000, the Top Panel starting with 
20000, the Structural Walls with 30000, etc.  This 
organization will make it easier to interpret and 
evaluate results later. 
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Lastly, for easier view manipulation, the model 
should be organized to quickly allow for portions to 
be displayed or hidden.  Two methods exist in 
FEMAP to help a user to control what portions of a 
model are visible at a time: groups and layers.  
Nodes and elements may exist in multiple groups, 
but only on one layer.  Multiple layers may be 
displayed simultaneously, but only one group may 
be displayed at a time.  While layers may seem 
advantageous, in that many views can be created by 
displaying only the layers needed, groups do offer 
an advantage that they may be used to select entities 
on which to operate (renumber, change color, etc).  
However, upon import into Thermal Desktop, only 
layers are preserved; therefore, a combination of 
groups and layers is recommended.  Groups should 
be used to define collections of elements on which 
to operate (or perhaps be viewed) and layers should 
be used for controlling visibility.   
 
6. MAKING A THERMAL MODEL FROM A MESH 
 
Once the mesh has been defined, it is exported as a 
FEMAP Neutral File v8.0 for further use in 
Thermal Desktop.  It could also be exported as an 
IDEAS Universal file for use in TMG or used with 
SINDA/ATM, but this paper focuses on the use of 
Thermal Desktop.  The neutral file is then imported 
into Thermal Desktop, where it is converted from a 
simple FE mesh into a thermal model.  This 
includes the need to define thermal boundary 
conditions and constraints (applied heat loads, 
environmental heating, radiation exchange, etc.), 
radiation enclosures, and solution parameters. 
 
The imported mesh includes all node locations, 
element definitions, material properties, and optical 
properties.  For element heat loads and radiation 
exchange factors, Thermal Desktop uses shape 
functions to apply energy to the corner nodes of an 
element.  During a ray trace, when a ray intersects 
an element the intersection point is first determined.  
This intersection point is then used along with shape 
functions for the element to apportion more of the 
ray’s energy to nodes closer to the intersection point 
and less energy to nodes further away.  This 
approach prevents all the energy from being applied 
to a single location (sub-element) as done in other 
codes.  A similar process is used to apportion 
element heat loads to the corner nodes. 
 
Radiation analysis groups are a means for defining 
enclosures, where elements in the enclosure can 

only “see” other elements in the enclosure.  Careful 
preparation and verification of the element normal 
direction and optical properties during the meshing 
process makes this much easier.  However, a user 
should still view the active sides and assigned 
optical properties within Thermal Desktop for each 
radiation group to ensure that the desired elements 
are participating in radiation exchange as expected. 
 
7. BASIC STEPS FOR MODEL GENERATION 
 
1. Import Solid Model Geometry  

a. File → Import → Geometry 
2. Generate Materials  

a. Model → Material 
3. Generate Properties  

a. Model → Property 
4. Determine Section of Model to Be Meshed 

a. Create Simplistic Surface representations 
where needed 
i. Geometry → Point 
ii. Geometry → Curve → Multiple Commands 
iii. Geometry → Surface → Multiple Commands 

b. Define Nodalization along Curves/Surfaces 
i. Mesh → Mesh Control → Size Along Curve 
ii. Mesh → Mesh Control → Default Size 

c. Generate Mesh and Assign Property 
i. Mesh → Geometry → Surface 
ii. Mesh → Geometry → HexMesh Solids 
iii. Mesh → Extrude 
iv. Mesh → Revolve 

d. Repeat for other sections of model 
5. Connect isolated mesh sections 
6. Check mesh 

a. Verify element normal directions 
i. View → Options → Element - Directions → 

Show Directions 
b. Merge nodes 

i. Tools → Check → Coincident Nodes 
c. Renumber to logical node/element groupings  

i. Modify → Renumber → Node 
ii. Modify → Renumber → Element  

d. Logically group section of the model 
together using Layers and Groups 
i. Modify → Layer → Node 
ii. Modify → Layer → Element 
iii. Group → Set 
iv. Group → Node → ID → Select Nodes 
v. Group → Element → ID → Select Elements 

7. Export FEMAP Neutral File v8.0 from FEMAP 
a. File → Export → FEMAP Neutral 

8. Import FEMAP Neutral File v8.0 into Thermal 
Desktop 
a. Thermal → Import → FEMAP ascii neutral (v8.0) 

9. Re-define orienters/anisotropic properties 
10. Define radiation analysis groups 



- 6 of 6 - 

11. Define orbital parameters 
12. Define applied heat loads 
13. Define analysis cases in Case Set Manager 
14. Run Cases 
15. Post Process 
 
In summary, the materials, properties, nodes, 
elements (including orientation), and layers are 
generated in FEMAP.  The material orienters and 
anisotropic properties are re-defined in Thermal 
Desktop, since they are not preserved in the export/ 
import process.  Furthermore, heat loads, radiation 
analysis groups, and orbital parameters are also 
generated in Thermal Desktop 
 
8. CONCLUSIONS 
 
The use of FEMAP to build a finite element model 
allows the thermal analyst to have better access to 
the design evolution as the solid model matures.  
FEMAP allows the user to make updates quickly 
without the need to regenerate a conduction 
network.  Recent advances in tools like Thermal 
Desktop and TMG allow for the quick generation of 
the radiation network.  Given the relatively simple 
remaining effort to add boundary conditions 
(applied power, heaters, etc.) and define the 
radiation environment (radiation groups, orbit 
parameters), the overall task of generating a thermal 
model can be mostly automated once a 
representative mesh is constructed. 
 

9. ACRONYMS 
 
FEM Finite Element Model 
FE Finite Element 
FEMAP Finite Element Modeling and PostProcessing.  

FEMAP is a product of UGS PLM Solutions, 
Inc. 

LISA Laser Interferometer Space Antenna 
TSS Thermal Synthesizer System.  TSS is a 

product of SpaceDesign 
SINDA Systems Improved Numerical Difference 

Analyzer.  SINDA/FLUINT is a product of 
Cullimore and Ring Technologies.  SINDA/G 
is a product of Network Analysis 

TMG Thermal Model Generator.  TMG is a product 
of MAYA Heat Transfer Technologies 

ATM Advanced Thermal Modeler.  SINDA/ATM is 
a product of Network Analysis. 
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